Heads up ! – EMC VNX2 – Potential Data Issue during NDU

This weeks HEADS UP ! and this time for us VNX2 users, courtesy of EMC TA email

Seeing  “Potential….Data Loss” in any ETA for equipment I admin raises my “Be Alert but not alarmed” counter.

Full Release here

This only affects upgrades to 05.33.000.5.074 which is the latest (Oct) Block OE and only if the “NDU DELAY” timer is changed from default. But for those wondering, what is the NDU DELAY timer?

During an upgrade, it is the delay (in seconds) that SPB will wait after rebooting before doing a rescan and marking paths available to itself, before continuing and rebooting SPA.

So effectively allow SPB to reboot, load completely and normalize all paths. Default value is 360, with a minimum of 0 and max of 1140.

The context in naviseccli is: naviseccli -h arrayaddressspa ndu -install VNX-Block-Operating-Environment-05.33.000.5.052.pbu -delay 420

So if you upgrade, don’t increase the NDU DELAY in USM, or if using naviseccli, don’t use the “-delay” parameter.  Option 3—Wait for a new release with the bug stomped !

That’s what I will be doing.

 


Severity Rating: Critical (Potential Data Unavailable or Data Loss )

Impact Description:
Customers that have increased the NDU DELAY timer prior to a Non-Disruptive Upgrade (NDU) to VNX Operating Environment (OE) for Block 05.33.000.5.074, may experience unrecoverable data, data loss, or data unavailable situations.


 

EMC Hardware: VNX5200
EMC Hardware: VNX5400
EMC Hardware: VNX5600
EMC Hardware: VNX5800
EMC Hardware: VNX7600
EMC Hardware: VNX8000EMC Software: VNX Operating Environment (OE) for Block Release 05.33.000.5.074
This issue occurs when the NDU DELAY timer is increased prior to a non-disruptive upgrade to VNX Operating Environment (OE) for Block Release 05.33.000.5.074.
Do not extend the NDU Delay above the USM default value prior to an upgrade to VNX OE for Block R33 05.33.000.5.074.If there is an urgent requirement to impose an NDU delay, do not upgrade your VNX OE for Block to version 05.33.000.5.074 and wait to upgrade your VNX OE until the next version of code.As a general recommendation, customers should always run a system health-check prior to installing any software upgrade and ensure that detected issues are resolved prior to the NDU.  Proceeding with the NDU before resolving issues detected from the health-check may potentially cause code upgrade or other issues to your system.EMC engineering is currently investigating this issue and will update this ETA as appropriate. Contact the EMC Customer Support Center or your service representative for assistance and reference this article ID.

 

 

Leave a Reply

Your email address will not be published. Required fields are marked *